Any attempted report has an invalid post identifier when TINYIB_REPORTCAPTCHA is enabled #202

Closed
opened 2 years ago by ChristopherCormier · 0 comments

This issue may only manifest with an SQLite3 database, or only with hCaptcha being used as the backend, as I haven't tested this thoroughly or narrowed it down very well and those are what I'm using with the TinyIB instance I found this on. If it can't be trivially reproduced on your side, I'm happy to put more time into figuring out the cause myself.

On the captcha page, there's a notice at the top that reads:

Notice: Trying to access array offset on value of type null in /var/www/html/imgboard.php on line 621

And then after filling out the captcha and continuing, it will reliably fail with "Sorry, an invalid post identifier was sent. Please go back, refresh the page, and try again."

This issue may only manifest with an SQLite3 database, or only with hCaptcha being used as the backend, as I haven't tested this thoroughly or narrowed it down very well and those are what I'm using with the TinyIB instance I found this on. If it can't be trivially reproduced on your side, I'm happy to put more time into figuring out the cause myself. On the captcha page, there's a notice at the top that reads: > **Notice**: Trying to access array offset on value of type null in **/var/www/html/imgboard.php** on line **621** And then after filling out the captcha and continuing, it will reliably fail with "Sorry, an invalid post identifier was sent. Please go back, refresh the page, and try again."
tslocum referenced this issue from a commit 2 years ago
tslocum closed this issue 2 years ago
Sign in to join this conversation.
No Milestone
No Assignees
1 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: tslocum/tinyib#202
Loading…
There is no content yet.